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Copyright Information: 
 
 2009 - Summit Computer Networks, Inc. – All Rights Reserved 
 
 
 
 

Introduction: 
 
TalkSwitch Logger is an application add-on for the TalkSwitch telephone system.  This 
application has two primary components to it.  The server component communicates with your 
TalkSwitch and downloads call activity logs, and then the client component will allow you to 
view those logs and generate reports and manage call usage for your clients. 
 
Only one instance of the server component will need to be run at any given time in order to 
poll the TalkSwitch for call data.  Clients can be run across the network in multiple instances to 
view and manipulate the data received from the TalkSwitch via the server component. 
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Features and Benefits: 
 
TalkSwitch Logger has the following features and benefits: 

• Centralized call log management. 
• Client Account call-time management. 
• Numerous call reporting capabilities. 26 different reports in all. All can be filtered by 

date and time ranges and days of the week can be included or excluded from report 
data. 

• Integrated backup and restore of critical data files. 
• Fully Networkable client can be run on multiple machines at the same time from across 

your LAN. 
• Friendly easy-to-use interface. 
• Developer Interface allows software developers to integrate functions of the 

TalkSwitch Logger directly into their own custom built applications. 

 

System Requirements: 
 

• At least 1 TalkSwitch telephone system with an Ethernet Interface. 
• At least 1 Windows PC with the following: 

Operating system 
 
• Windows 2000 
• Windows 2000 Advanced Server 
• Windows XP 
• Windows Server 
• Windows Vista (32-bit & 64-bit) 
 
Computer hardware 
 
Minimum: 
• Celeron or Pentium 3 Processor 
• 256 MB RAM 
• 30 GB Hard Disk 
• Network Interface Card 
 
Recommended: 
• Pentium 4 Processor or Better 
• 512 MB RAM or Better (1 GB on Vista). 
• 80 GB Hard Disk 
• Network Interface Card 
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Getting Started (Server): 
 
After installing the TalkSwitch Logger on your computer system you will need to first 
configure the server-side application.  To do this go to the Windows “Start” menu and select 
“All Programs” → “TalkSwitch Logger” → “TalkSwitch Log Server”.  This part of the 
program runs on a single computer and will show up in the system tray (on the taskbar near the 
clock). 
 

 
 
To begin configuring the server, right-click on the icon in the task tray and then select 
“Configure TS Log Server” from the menu. 
 
 

 
 
 
Once you select the configuration option on the popup menu, you will see a window like the 
one pictured above.  Fill in the information in this window as it pertains to your TalkSwitch 
system. 
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Unit IP Address: 
The first thing you will need to fill in is the IP address that you have assigned to your 
TalkSwitch unit.  This can be found by running the TalkSwitch configuration software and 
looking on the “IP Configuration” selection.  You will want to make sure that you are manually 
configuring the IP address (“Use Configured IP and DNS information”) on your TalkSwitch so 
that the IP address remains constant and the TalkSwitch Log Server can always locate your 
TalkSwitch unit. 
 
 
Port: 
This is the port that the TalkSwitchs' built-in web server is using.  By default the TalkSwitch is 
set to 8484.  You can find this setting in the TalkSwitch Configuration software under the 
"Troubleshooting" -> "Extensions" -> "IP Extensions" menu. 
 
 
TimeOut Secs: 
This sets how long that the server should wait for a response from the IP network and the 
TalkSwitch unit.  The default value of 5 seconds should be more than enough for most 
situations.  If you are running the server over the internet or on a slow LAN, then a higher 
timeout value may be needed.  This amount is the max amount of time that the server will wait 
for a response before generating an error. 
 
 
Poll Int Mins: 
This tells the server how often to download logs from the TalkSwitch.  If you set this value to 
60, then the TalkSwitch would be scanned for updated calls once every hour.  A setting of 15 
minutes should be a good setting for most people since the call logs would be refreshed fairly 
often.  Adjust this setting to your needs.  Valid settings are from 1 minute to 300 minutes (5 
hours).  If you experience lighter call loads or don’t refer to your logs very often, you can use 
higher poll times to reduce network traffic on your LAN. 
 
 
User Name: 
This is the name that is required to log into your TalkSwitch unit.  This name is set in the 
TalkSwitch configuration software on the “Administration” page as “System Name”. 
 
 
Password: 
This is the password that is required to log into your TalkSwitch unit.  This must match the 
password that you have setup in your TalkSwitch configuration software on the 
“Administration” page as “System Password”. 
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Data Directory Location: 
Click on the  button and select the folder where you want the server to create and keep its 
data files.  Clients will need to have full access to the folder selected here.  This folder could be 
the same location where you installed the software but is not recommended. 
 
 
After you have set the above fields, click on the Save button to save your changes. 
 
You will now need to install  your license on the server in order to run the server. 
 
 

Installing Your License: 
 
 
To install your license right-click on the server icon in the system tray and select “Install 
License Key” from the popup menu. 
 
Enter your license name and key as given to you into the supplied fields and then click the Ok 
button to save these changes.  You can verify that your license has been properly installed by 
visiting the “About TS Log Server” menu option or double-clicking on the task tray icon. 
 
 
Obtaining a trial license key: 
 
If you downloaded the software from the Internet you will need to obtain a Trial License Key 
from Summit Computer Networks, Inc..  You may email a request to info@summitcn.com or 
you may call 888-452-3847 or 724-779-6390 to request your free trial license key.  Before 
emailing or calling you must have the following information ready beforehand. 
 
Name or Company Name: ________________________________________ 
 
Contact Phone: _______________________________________________ 
 
*TalkSwitch MAC Address:  ____________________________________ 
 
*to get your TalkSwitch unit’s MAC Address you can double-click on the TalkSwitch Log 
Server icon in the Windows task tray provided that the IP Address has been properly 
configured as mentioned earlier in this document.  The MAC Address will be shown as 
“Hardware Address” on this page.  You may also find the system’s MAC Address by running 
the TalkSwitch configuration software and selecting “My TalkSwitch System”. 
 
Double-check that your MAC address is accurate and then email the address (with or without 
the dashes) to the email address above, or call one of the numbers above to receive your free 
trial license key.  Only one trial period per user/company  will be given. 

mailto:info@summitcn.com


TalkSwitch Logger Documentation                                                                                    - 6 - 

Preparations: 
 
Before you can begin using the TalkSwitch Logger you need to make sure that your 
TalkSwitch system is setup for CDR to be stored on the unit.  Go into the TalkSwitch 
configuration software and select the “Tools” menu and then select “Call Logging Output 
(CDR)…”  You will see a window like the one below. 
 

 
 

 
Make sure that you select “Store to file on TalkSwitch” as the option on this window and make 
sure that the unit that you will be storing the log on is the same one that you set the IP address 
to in the configuration step of this document.  Click Ok to save your changes. 
 
Configure the TalkSwitch Log Server as mentioned earlier in this document and install your 
license.  Keep in mind that if you want the data to be available to your other network users, 
either point the servers data folder to an already shared network folder, or create a new folder 
and share it on the network, and have the server use this folder as the data folder. 
 
Run the TalkSwitch Log Server by right-clicking on the icon in the Windows task tray and 
then selecting “TS Log Server Running” from the popup menu.  The Red X that was on the 
icon should now disappear showing that the server is up and running.  The first poll will take 
place in approximately 30 seconds after the server has been started.  If you still see the red X 
through the icon, then double-click the icon and go to the “Current Log File” tab to review the 
server log.  Scroll down to the bottom of this page and you should see an error message as to 
why the server could not start.  Correct the problem then re-start the server. 
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If you would like the server to automatically load at boot time, right-click on the task tray icon 
and select “Launch at System Boot” from the menu.  A check mark will appear next to this 
menu option when it is enabled. 
 
You can double click on the server icon or right-click and select “About TS Log Server” from 
the popup menu to get to the server information window. 
 
 
 

Server Controls: 
 
Icon Right-Click Menu: 
 

The right-click menu shown to the left is available by right-clicking 
on the TalkSwitch Log Servers task tray icon.  Each item on the 
menu will be discussed below. 
 
About TS Log Server – This will open the About Server window 
which is pictured on the next page. 
 
TS Log Server Running – This will start and stop the server.  
When the item has a checkmark next to it, the server is running. 
 
Launch at System Boot – When this item is checked the log server 
will automatically start up when Windows boots up. 

 
Configure TS Log Server – This will open the server configuration window.  This is where 
you will set the IP address and other settings relating to your TalkSwitch unit. 
 
Install License Key – This will open the License Installation Window.  Use this to install your 
license name and key into the server. 
 
Archive Current Log File – This will remove any entries from the current log file that are not 
from the current year and place them into an archive file.  The archive files can be selected 
from the client module for reporting.  Each year is placed into its own archive file.  Before 
doing this make sure that all calls from prior years have been processed for any accounts that 
they may be assigned to. 
 
Refresh Data Now – This will force the server to Poll the TalkSwitch unit immediately and 
download the call logs.  This will override the next poll that was scheduled, and it will be 
rescheduled for however many minutes are set in the poll interval. 
 
Exit TS Log Server Now – This will completely shutdown the server application and unload it 
from the task tray. 
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Whenever you double-click on the task tray icon, you will see the About Server window 
(pictured above).  This window will give you general information about your server as well as 
allow you to view the current and previous server logs and a list of recent calls. 
 
The “About Program” tab shows information about the server license, IP address, Hardware 
(MAC) Address, running state,  poll count and error count, poll interval, and data folder. 
 
The “Current Log File” and “Previous Log File” tabs allow you to view Server Logs (not call 
logs).  The server logs will show information such as poll data received, any errors, and server 
startups and shutdowns. 
 
The “Recent Calls” tab will allow you to see the last 7-days worth of call logs as downloaded 
from your TalkSwitch. 
 
This entire window is only refreshed when it is first opened, so the data is not updated again 
until you close the window and re-open it. 
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Getting Started (Client): 
 
Once you have your server up and running properly, you can setup your client.  You can install 
“client-only” installs on as many machines as needed on your network.  After installing the 
client application, launch the client and then go to the “options” menu and select “Set Data 
Path”. 
 

 
 
Nothing will work on the client until you point it to the main data folder where the server is 
writing the log files.  After setting the data path, verify that it is correct by selecting the “Call 
Detail Log” item (top right side). 
 

 
 
If you get the report options window (shown below), then your data path was properly set.  If 
nothing at all happens, then either there is not a log file present, or you have selected the wrong 
folder location. 
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Now that you have your data folder location set, there isn’t any further setup issues to worry 
about on the client side.  You are now ready to begin managing client accounts, and call data. 
 

 
Client Account Management: 
 
Managing client accounts is really one of the core tasks of the TalkSwitch Log Client program.  
Client accounts can be assigned calls from the call log either from your extension or by using 
the Account Editor. 
 
To assign an account number to a call using your extension, at the end of the call, pick up the 
handset again and dial *88 followed by the account number, followed by the # sign.  You 
should hear a recorded prompt that says “Accepted”.  If you make a mistake entering the 
account number you can enter it again by repeating this process.  The TalkSwitch Logger will 
use the last account assignment when downloading the log from the TalkSwitch unit. 
 
Since you can assign account numbers using your extension, it is therefore possible to have 
calls in the log assigned to accounts that do not exist in the TalkSwitch Logger. 
 
To create a new account either select the “Create New Account” option from the “Tools” menu 
or click on the “Create New Account” on the left side of the main Client window. 
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After selecting this option you will need to enter an account number for the new account that 
you wish to create.  Enter the number in the window, and then click on the Ok button.  The 
client will then create the new empty account record and then open it in the account editor 
(pictured on next page). 
 
Accounts can also be created from within the Account Editor by selecting the “Account” menu 
bar item and then selecting “New”.  You can also delete the current account on this same menu 
by selecting the “Delete” item. 
 
To open an existing account use the “Edit Account” option from the main client window.  You 
can edit a specific account number or leave the account number field blank to simply open the 
editor on the first account. 
 

 
 
 

 
 
The account editor is very easy-to-use and you only need to enter in minimal data.  The current 
account # will be shown on the top title bar and all other information will be shown in the 
fields and stats sections of the window. 
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Basic Navigation of accounts: 
 
Moving between accounts is as easy as clicking on the Previous or Next buttons.  These 
buttons will step up or down to the next logical record based on whatever the current index 
selected is in the area between these buttons.  You can step through records by Account#, Last 
Name, or by Company Name.  On the “Account” menu item at the top of the window, you will 
also find First and Last items which will go to the logical first or last record for whatever 
index you have selected. 
 
You can also choose to Search for accounts based on criteria you provide.  To search account 
records select “Account” on the menu bar, and then “Search”. 
 

 
 
To begin a search, type in some search text in the space provided at the top of the search 
window.  Choose the field to search and what rule you would like applied to your search, and 
then click the Search button on the upper right corner of the window. 
 
Rules will determine what results are shown in the search window.  If  you select Match 
Exactly then only search results matching your text exactly will be shown.  This does not 
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apply to upper or lower case, since searches are not case sensitive.  If you select Match Begins 
With then all records whose first part of the field selected match your search text will be 
shown.  If you select Match Contains then all records that have your search text in any part of 
the field being searched will be returned. 
 
If you place a check in the box at the bottom left labeled Automatically close search and go 
to account on single match, then any subsequent searches that only yield a single result will 
automatically go directly to the account closing the search window. 
 
Select the record that you want to view and either double-click it or highlight it and click the 
Ok button.  The search window will close and the editor will now have the account loaded that 
you selected. 
 
Search Fields email and postal addresses and the rule Match Contains are non-indexed 
searches and may be slower than the other searches which use internal file indexes.  This really 
depends on factors such as the number of client accounts stored, network speed, and computer 
speed.  Even non-indexed searches are very fast in most cases. 
 
Anytime that you are about to leave an account record that you have changed, you will be 
prompted as to whether or not you would like to save the changes.  If no changes have been 
made you will not be prompted. 
 
 
Call Assignments: 
 
Calls can be assigned to accounts by using the *88 option from a TalkSwitch extension as 
mentioned earlier, or you may manually assign calls to an account from the editor.  Open the 
account that you want to assign calls to in the Account Editor and then either click on the Call 
Assignments button on the bottom left of the window or select the “File” menu and then select 
“Assign Calls”. 
 
This will open the Assign / Un-Assign Calls window.  The list will only show calls that have 
already been assigned to this account whenever you first open it.  To see a list of all available 
(calls that are not yet assigned to any account) calls select the top right option labeled Un-
Assigned Calls.  The list will now populate with all un-assigned calls. 
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After the calls have been displayed in the list you can further narrow your search by typing in 
part of a phone number, caller ID name, IN, OUT or any other line data and clicking on the 
Filter List button. 
 
Once you have located one of the calls that you want to assign, double-click the call in the list 
or highlight it and click on the Assign / Un-Assign Call(s) button.  You will be prompted for 
This Call Only or All Matching Calls.  This call only changes only the selected call assigning 
it to the current account.  All Matching calls will find any other calls that have not been 
assigned to an account with the same phone number and assign them to the current account. 
 
To Un-Assign any calls you must first select the Currently Assigned Calls option in the upper 
right corner of the window and then highlight or double-click on any calls from the list that you 
wish to un-assign. 
 
If you have previously assigned calls to the account either using a TalkSwitch extension or the 
account editor, you can use the Smart Add button in the upper left corner to automatically 
scan the current call log for any calls with billable time whose numbers match the numbers 
already assigned to the current account and that have not yet been assigned. 
 
Only calls that have billable minutes can be assigned, so calls that never went to an extension 
will not even be available in the list. 
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Call Accounting: 
 
Once calls have been assigned to an account you will then want to add minutes to the account 
(Free or Paid) by selecting the “File” menu from the Account, and then selecting “Add 
Minutes”. 
 

 
 
Enter an amount, select whether they are free or paid minutes, and if they should expire or not 
and then click the Ok button.  Minutes are immediately added to the account and saved.  To 
cancel this window, leave the amount field blank, and click the Ok button to close the window 
without adding any minutes. 
 
You can also remove or “zero” the minutes for a given account and reset or disable the 
expiration date.  Removing minutes will not change the “Paid Minutes Ever” or “Free Minutes 
Ever” stats.  Only the “Minutes Remaining” amount will be effected. 
 
To remove or zero minutes select “Remove or Zero Minutes” from the “File” menu on the 
account. 
 
To reset the expiration date or to clear it select “Change Expiration Date” from the “File” menu 
on the account. 
 
 
To actually bill calls to the account use the Process Calls button on the account, or from the 
“File” menu.  There is also a Process Calls option on the main client application that will 
process calls for ALL client accounts.  The option in the Account Editor only processes calls 
for that account. 
 
 
Other Account Related Activities: 
 
Phone numbers are not stored in the client’s account record.  Phone numbers are obtained by 
searching the log file for calls assigned to that account number.  Use the Find button to 
populate the “Current Phones” list while in the Account Editor.  This list will also be 
automatically populated when exiting the Call Assignment area. 
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The Reference/Cust ID field can be used to keep an account number from another application 
for the client or for anything else you like. 
 
A “Call Detail Log” report for the current account can also be accessed from the Account 
Editor by selecting “Reports” → “Call Detail Log” from the menu at the top of the editor.  This 
report is also available from the main client window. 
 
 

Reports: 
 
The other core task of the TalkSwitch Log Client Program is its reporting features.  The reports 
are all accessible from the main client window as well as the “Reports” menu. 
 
The reports will all use the Current Log File data unless you specify otherwise by selecting the 
“Set Current Log Data” option from either the main client window or from the “Options” 
menu.  If you wish to view reports for an archived year, use this option to select a new report 
file.  The currently selected report file will show on the main client window on the left side. 
 

 
 
To change your selection, use the “Set Current Log Data” option again and select a new file.  
Selecting the file TSLogger  (TSLogger.dat) will restore the reports to using the current data.  
The current data file is selected by default whenever you start the client program.  *Changing 
the current log file has no effect on “Account Reports” (Reports on client accounts). 
 
 
Report Filters: 
 
Different reports have “report specific” filter options as well as the general parameters such as 
starting and ending dates and times.  You can also choose to exclude certain days of the week 
on most of the reports.  A typical report parameter window is shown below. 
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The topmost drop-down box is the “Report Specific” parameter setting.  Not all reports have 
this option, and options will differ from report to report. 
 
The next drop-down box is the “Date/Time Range” box.  You can choose from some “built-in” 
options such as “This Month”, “This Year”, “Last Month”, etc. or you can choose to 
“Manually Set Range” which will enable the Time & Date controls for the Start and End 
periods. 
 
The next thing on this window is the “Search Text” area.  This area will only be available on 
reports that need additional search data.  To the right of the text box, are 3 options that allow 
you to configure how the search text is used.  These options may also not be available in some 
reports. 
 
Finally the last section contains the days of the week which should be included in the report.  
These are all checked by default so you can uncheck any days that you do not want to include 
in your report data. 
 
Also keep in mind that no matter what you set as a starting and ending date range only calls 
from the selected log file will be available in the report.  Setting a date earlier or later than 
what the file contains will not automatically include other files. 
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Viewing or Printing Reports: 
 
Once you have setup the filter data,  you will click the green check button to generate the 
report.  The report will open in a viewer that will allow you to save this report as a self-viewing 
program and/or print the report.  When you save the report it becomes a Windows exe file that 
can be moved and later viewed or printed from another computer. 
 

 
 
This is what the report viewer looks like.  You can preview any reports before printing them, or 
simply view them on-screen without actually printing them at all. 
 
 
List of Reports: 
 
Below is a general list of reports available along with their options in this version of the 
TalkSwitch Logger. 
 

• Call Log Detail (Inbound / Outbound / All) 
• Call Log Detail for an Account (Inbound / Outbound / All) 
• Calls by Phone Number (Inbound / Outbound / All) 
• Calls by Caller ID Name 
• Calls To/Fr a line, extension or voice mailbox (Inbound / Outbound / All) 
• Calls by Access Code 
• Blocked Calls 
• Billed Time vs. Queued Time Pie Chart 
• Call Statistics 
• Usage Minutes by Line and by Extension 
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• Client Accounts that expire before a certain date 
• Client Accounts with less than x minutes remaining. 

 
 
 

Client Utilities: 
 
The TalkSwitch Logger utilities allow you to process unbilled calls, backup and restore your 
data, export data, and edit the exported data using the CSV editor. 
 
 
Process Calls: 
 
The Process Calls option will go through the current call log and look for calls that have not 
yet been billed.  Whenever a call is found the account that the call belongs to is updated to 
reflect the call minutes used for the call, and the call is then marked as “billed”.  This feature 
works much in the same way as the Process Calls button found in the Account Editor 
(mentioned earlier), the difference being that this utility will process calls for ALL accounts. 
 
 
Backup / Restore: 
 
This feature allows you to backup all of the data files created by the TalkSwitch Logger to a 
single file on a drive of your choice.  It is recommended to backup your data files on a regular 
basis.  This is especially true before doing anything major to your data files such as archiving 
the logs or adding or deleting numerous client accounts. 
 

 
 
To backup your data, first select the destination for your backup by using the “Backup Drive” 
drop-down box.  Next click on the Backup button.  The backup file will be stored in a folder 
named TSLGR_BACKUPS on the selected drive.  TalkSwitch Loggers' backup files are 
named in a manner that will help you identify which file you want when looking at multiple 
backups. 
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Typical File Name:  TSLGR08052001.BKP 

 
The first part of the file name will always be TSLGR and the extension will always be .BKP.  
Files stored on floppy disks will only be called TSLGR.BKP and may span multiple disks.  If 
you are using floppies for backups, make sure that you properly number your disks as they are 
created.  The middle part of the disk file name is numeric.  The first 2 digits represent the year 
‘08’ being 2008, followed by the next 2 digits which are the month ‘05’ being May, followed 
by the 2-digit day, and finally a 2-digit revision or backup count for that day.  So the first 
backup for the day would end in 01, and the second 02, and so forth. 
 
Restoring Data: 
 
Remember Backup means from the computer to a backup file, and restore means to take the 
backup data from a previous backup and restore it to the computer.  This will make the files 
exactly the same as they were at the point in time in which the backup was made. 
 
Choose the drive to restore from in the “Backup Drive” drop-down box and then click on the 
Restore button. 
 
Whenever you go to restore a file, you will first be prompted to overwrite the existing data 
followed by a file selection if more than one backup file exists on the drive that you have 
selected.  If only one file exists, then the restore will begin immediately after answering yes to 
the overwrite files prompt. 
 
*Note: The Backup button will be disabled whenever there is no data present in the currently 
selected data folder.  This could be that you have improperly selected your data folder in the 
client options or that there is simply no data to backup. 
 
 
 
Export Data: 
 
The TalkSwitch Logger allows you to export your call log data or your client account data to a 
standard comma-delimited ASCII file known as a CSV file.  This type of file is widely 
recognized by other applications such as Excel and can be read by these other applications.  
This will allow you to do custom reporting or graphs using your data from the TalkSwitch 
Logger. 
 
To Export Log files go to the “Tools” menu and select “Export Calls”.  When exporting calls 
you will first need to select which log file to use.  The default (or current) log file is called 
TSLogger.dat, and the archive files are all called “Archive-xxxx.dat” where the xxxx = the 
year of the data contained in that particular file.  Once you select which file to export, you will 
next need to pick a CSV file name.  This is the file that the system will create and place your 
exported data into.  Select the file and click on the Save button to begin the export process. 
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To Export Client Accounts go to the “Tools” menu and select “Export Accounts”.  You will 
then be prompted for a CSV file name to save the export data to.  Enter a file name and then 
click on the Save button to begin the export process. 
 
If you would like to view a CSV file that you have exported go to the “File” menu and select 
“CSV Editor”.  This will open the CSV file editor with no data loaded in it.  Click on the “File” 
menu in the CSV editor and select “Open”.  Select the CSV file from the open file dialog and 
then click Open.  The editor will now show the contents of your CSV file.  You can double-
click on any record (line) to edit its contents. 
 
 
Legal: 
 
Do not share your license codes with others or use them at other locations other than the one 
that was originally purchased.  If you own multiple locations, you will need to license each 
location individually.  Any licenses that are used illegally will be deemed useless for future use 
and/or upgrades. 
 
Licensing the product legally ensures that we will have the funding available to continue future 
development of this product and its add-ons.  Your help is greatly appreciated! 
 
For current license pricing and add-on pricing please visit our web site at www.summitcn.com. 
 
Also visit our web site for the most recent updates available for the TalkSwitch Logger. 
 

http://www.summitcn.com/
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